All About the Updater Plugin

Tutorial Tuesdays
With the anticipated release of Vantage 1.1 coming this week, we have prepared and released our new AppThemes updater plugin. The plugin is going to make updates easy and a simple. Dave has created a full blog post about the updater. We suggest giving it a quick read to see what the updater is all about.

This tutorial Tuesday is going to be sweet and simple. We’re going to show you how to install and use the new updater plugin. Dave has a nice written tutorial with instructions on how to install the new AppThemes updater plugin. Once you have it installed, check out the video created by Vantage developer Josh Ronk. In the video, Josh shows us how to use the updater plugin to update a theme.

These tutorials are very brief. But that’s because the updater is that straightforward and uncomplicated. It’s also the best way to update all our themes. So hop on over and check it out then download your own copy of the AppThemes updater plugin.

Your rating: none
Rating: 5 - 1 vote

 Comments (12)

  • mprakashm

    Hi Shannon,

    Thanks for the updater, I installed Vantage in my new WordPress Multisite. Main site is Vantage, and other sub directories are free themes that my users can post their blogs, I am plan to give those blogs to my Premium members, so that they can easily add their updates…

    So I am waiting for Vantage1.1 to start this project… I setup every thing perfectly in vantage 1.0.1 except payment items. and this updater not working in my main website theme… its keep on asking me enter api key… i added 3 times..

    This plugin not support WordPress multisite?

    Like
    • staff
      David

      @mprakashm, the plugin supports multisite but not the “Network Activate” plugin option. We’re working on a fix which will be bundled in the version 1.1 of the plugin. For now, you need to activate the plugin on each sub-site and enter the same API key on all of them. Thanks for pointing this out.

      Like
      mprakashm likes this.
      • mprakashm

        Dear Mr. David,

        Thanks for your kind fast response, and in the Listings new users (Subscribers) not able to add tags in vantage 1.0.1, hope this will be fix 1.1

        Thanks

        Like
        Anonymous likes this.
  • customer
    classifiedstheme

    I installed the AppThemes Updater plugin. Now it says “You have version 1.0-beta installed. Update to 1.0. View version 1.0 details.”

    When I try to install it returns “Downloading update from http://api.appthemes.com/plugins/dow…ter&api_key=my key…
    Unpacking the update…
    An error occurred while updating AppThemes Updater: The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature.”

    What is wrong?

    This is the link to the thread I created:
    http://forums.appthemes.com/appthemes-updater-35902/

    • staff
      David

      @classifiedstheme, thanks for letting us know. I’ve responded to your forum post. We’ll keep you updated there.

      Like
  • customer
    classifiedstheme

    Thanks

  • customer
    circlecity

    Is this working if your using a child theme?

    • author
      Shannon

      The updater should update your AppThemes theme. It will not update the child theme. Is that what you mean?

  • Michael

    Yes, I’m using a child theme and so far I can’t get the updater to update the main vantage theme. I get no notification on an update available. Is there a forum spot that this could be addressed?

  • Young Master

    Thank you for this plugin…Will this update affect the code modified in this theme as many people modified the code to introduce new features into their themes eg: Featured ribbon, sold stamp, sold tag etc. Am Using classipress. If yes what do you advise your who have modified their theme codes to do before updating the theme?

    • author
      Shannon Dunn

      Yes, the plugin will write over any changes made to the theme’s core code. If you want to customize your theme, we absolutely recommend that you so do with a child theme. This is the best way to ensure that updates will not interfere wit your customizations. We have several tutorials about creating child themes in our documents section.

Discussion is closed.